Как найти значения с помощью ИНДЕКС в Microsoft Excel

Логотип Microsoft Excel на зеленом фоне

Когда вам нужно получить значение, которое находится в определенном месте вашей электронной таблицы, вам понадобится одна из функций поиска и ссылок Excel. Здесь мы покажем вам, как найти значения по местоположению с помощью ИНДЕКС в Excel.

Возможно, вы создаете сложную формулу или у вас часто меняются значения. Используя функцию ИНДЕКС, вы указываете диапазон ячеек вместе с номером строки и номером столбца. Excel находит значение на этом пересечении и предоставляет результат формулы.

Функция ИНДЕКС в Excel

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

Вы можете использовать функцию ИНДЕКС двумя разными способами в Excel: в форме массива и в форме ссылки.

Формы функции ИНДЕКС в Excel

Форма массива предоставляет значение определенного диапазона ячеек или массива. Справочная форма предоставляет ссылку на определенные ячейки и полезна при работе с несмежными ячейками.

Давайте посмотрим, как использовать оба.

Использовать ИНДЕКС в форме массива

Синтаксис функции в форме массива: INDEX(массив, номер_строки, номер_столбца), где первые два аргумента обязательны, а номер_столбца необязателен.

Чтобы найти значение в третьей строке диапазона ячеек от C1 до C10, введите следующую формулу, заменив ссылки на ячейки своими собственными.

=ИНДЕКС(C1:C10,3)

Число 3 здесь представляет третий ряд. Вам не нужен аргумент номера столбца, потому что массив находится в одном столбце, C.

ИНДЕКС в форме массива для строки

Чтобы найти значение в третьей строке и пятом столбце для диапазона ячеек от A1 до E10, вы должны использовать эту формулу.

=ИНДЕКС(A1:E10,3,5)

Здесь 3 представляет третью строку, а 5 представляет пятый столбец. Поскольку массив охватывает несколько столбцов, вы должны включить аргумент номера столбца.

ИНДЕКС в форме массива для перекрестка

Использовать ИНДЕКС в справочной форме

Синтаксис функции в справочной форме: ИНДЕКС(ссылка, номер_строки, номер_столбца, номер_области), где первые два аргумента являются обязательными, а вторые два необязательными.

Вы можете использовать базовую формулу с справочной формой функции, как и с формой массива. С помощью следующей формулы вы получите значение в третьей строке и пятом столбце ячеек от A1 до E10, как и выше.

=ИНДЕКС(A1:E10,3,5)

Итак, давайте рассмотрим более надежную формулу с этой формой функции ИНДЕКС, использующей несмежные ячейки.

Здесь мы используем два диапазона ячеек: от A1 до E4 (первая область) и от A7 до E10 (вторая область). Чтобы найти значение в третьей строке и четвертом столбце в первой области, введите следующую формулу:

=ИНДЕКС((A1:E4,A7:E10),3,4,1)

В этой формуле вы видите две области: 3 для третьей строки, 4 для четвертого столбца и 1 для первой области от A1 до E4.

ИНДЕКС в справочной форме для первой области

Чтобы найти значение, используя те же диапазоны ячеек, номер строки и номер столбца, но во второй области вместо первой, вы должны использовать эту формулу:

=ИНДЕКС((A1:E4,A7:E10),3,4,2)

Как видите, все остается прежним, за исключением того, что вы заменяете 1 на 2 для второй области.

ИНДЕКС в справочной форме для второй области

Удобно помнить о функции ИНДЕКС в Excel. Если вы планируете часто использовать функции поиска и ссылок, обязательно ознакомьтесь с тем, как использовать ВПР для диапазона значений и как использовать КСПР в Excel.

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован.