Как использовать СУММЕСЛИ в Microsoft Excel

Логотип Microsoft Excel на зеленом фоне

Сложение чисел в Microsoft Excel — это базовое вычисление, которое может использовать функцию СУММ. Что, если вы хотите добавить эти значения, но только если они соответствуют определенным условиям? В этот момент на помощь приходит функция СУММЕСЛИ.

С помощью СУММЕСЛИ вы можете добавлять значения в указанные вами ячейки, если они соответствуют определенным критериям. Возможно, вы хотите найти общий объем продаж, но только для определенных продуктов, или общий доход, но только для определенных местоположений.

Если ваш лист Excel настроен таким образом, что ваш расчет нелегко определить, может помочь функция СУММЕСЛИ и ее формула.

Используйте СУММЕСЛИ для диапазона одной ячейки

Синтаксис функции: СУММЕСЛИ(диапазон_ячеек, критерии, диапазон_суммы), где требуются первые два аргумента. Поскольку диапазон_суммы не является обязательным, вы можете добавить числа в один диапазон, которые соответствуют критериям в другом.

Чтобы получить общее представление о функции и ее аргументах, давайте начнем с использования одного диапазона ячеек без необязательных аргументов.

Вы можете добавлять значения в диапазон ячеек, только если они превышают определенную сумму. Введите следующую формулу, заменив ссылки на ячейки и критерии своими собственными.

=СУММЕСЛИ(C2:C7;»>25000″)

Эта формула складывает числа в диапазоне ячеек от C2 до C7, только если они больше 25 000.

СУММЕСЛИ с использованием больше, чем для одного диапазона ячеек

С другой стороны, вы можете добавлять числа, которые меньше определенной суммы, используя эту формулу:

=СУММЕСЛИ(B2:B7;»<10000")

Это добавляет числа в ячейках с B2 по B7, только если они меньше 10 000.

СУММЕСЛИ использует меньше, чем для одного диапазона ячеек

В качестве еще одного примера вы можете сложить числа, равные одной сумме, с помощью этой формулы:

=СУММЕСЛИ(A2:A7;»5000″)

Это добавляет числа в ячейках от A2 до A7, только если они ровно 5000.

СУММЕСЛИ с использованием равенства для одного диапазона ячеек

Используйте СУММЕСЛИ с числовыми критериями для нескольких диапазонов

Теперь давайте задействуем этот условный аргумент, sum_range. Здесь мы считаем расходы и доходы. С помощью СУММЕСЛИ мы можем рассчитать доход для местоположений, расходы которых соответствуют нашим критериям, и наоборот.

С помощью этой формулы вы можете добавить доход в ячейках с C2 по C7, только если расходы в ячейках с B2 по B7 меньше 10 000.

=СУММЕСЛИ(B2:B7;»<10000",C2:C7)

СУММЕСЛИ с использованием меньше, чем для нескольких ячеек

Используя следующую формулу, вы можете добавить расходы в ячейках с B2 по B7, только если доход в ячейках с C2 по C7 превышает 25 000.

=СУММЕСЛИ(C2:C7;»>25000″,B2:B7)

СУММЕСЛИ с использованием больше, чем для нескольких ячеек

Вы также можете заменить фактическое значение в формуле на значение, содержащееся в ячейке. Например, эта формула складывает числа от B2 до B7, если значение от C2 до C7 больше, чем значение в ячейке D2.

=СУММЕСЛИ(C2:C7,»>»&D2,B2:B7)

В этой формуле используется символ «больше» («>») и ячейка D2 (&D2).

SUMIF с использованием больше, чем ячейка

Используйте СУММЕСЛИ с текстовыми критериями для нескольких диапазонов

Возможно, значения, которые вы хотите добавить, соотносятся с текстом, а не с числами. Здесь у нас есть типы, продукты и продажи. Используя СУММЕСЛИ, вы можете добавить значения в столбце «Продажи» для продуктов, которые соответствуют определенным условиям в других столбцах.

В этом примере вы можете добавить продажи в ячейки с C2 по C7, только если текст в ячейках с A2 по B7 равен слову «Одежда».

=СУММЕСЛИ(A2:B7;»Одежда»,C2:C7)

СУММЕСЛИ равняется слову для нескольких ячеек

В качестве другого примера вы можете добавить продажи в ячейки с C2 по C7 для продуктов в ячейках с B2 по B7, которые заканчиваются на «ts».

=СУММЕСЛИ(B2:B7;»*ts»,C2:C7)

В этой формуле звездочка

является подстановочным знаком, представляющим любые буквы перед «ts».

SUMIF заканчивается буквами в нескольких ячейках

Еще один пример использует наш продукт Shoes, тип которого не указан.

=СУММЕСЛИ(A2:B7,»»,C2:C7)

В этой формуле кавычки стоят рядом без пробела между ними.  Это дает нам продажи обуви, как показано ниже.

SUMIF с использованием пробела для нескольких ячеек

Функция СУММЕСЛИ в Excel позволяет вам взять базовое уравнение и приправить его в соответствии с вашими потребностями. Это очень удобно, когда сложение чисел не так просто, как два плюс два.

Для получения дополнительной помощи посмотрите, как найти нужную функцию в Excel.

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован.